Error : composer require --dev zendframework/zend-expressive-tooling

I want to install ----- zend-expressive-tooling,
Enter – $ composer require --dev zendframework/zend-expressive-tooling
Result :
Install nothing or upgrade
The http-interop / http-middleware package is left, you should avoid using it. Use http-
interop / http-server-middleware instead.
The phpunit / phpunit-mock-objects package is not used, it should be avoided. No
replacement has been proposed.
The webimpress / http-middleware-compatibility package is abandoned, you should avoid using it. Use psr / http-server-middleware instead.

Open Server / php 5.6 / Windows 10/

Seems like it’s already installed then :wink:

1 Like

zend-expressive-tooling needs PHP in version 7.1 or higher:

You are using an old and unsupported version of PHP.

1 Like

Why is there no entry in composer.json about this?

“scripts”: {
“post-create-project-cmd”: [
@development-enable
],
“development-disable”: “zf-development-mode disable”,
“development-enable”: “zf-development-mode enable”,
“development-status”: “zf-development-mode status”,

    "check": [
        "@cs-check",
        "@test"
    ],
    "clear-config-cache": "php bin/clear-config-cache.php",
    "cs-check": "phpcs",
    "cs-fix": "phpcbf",
    "serve": "php -S 0.0.0.0:8080 -t public public/index.php",
    "test": "phpunit --colors=always",
    "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}

Which composer.json do you mean?

composer.json for your project is your responsibility.
Settings like versions of PHP are something you have to change yourself.
So, as an example, open the .composer.json file in your project root and add line 24 from above example to the top of your "require" section.
After that run a composer update and see what happens. Probably not much, since you are running PHP5.6 on your machine, in that case I would start with updating that first.