Flash-messenger installation problem


#1

Hi, everybody,
i hope someone cah help me…

for short :
I can not install the flash messenger plug in…

i use the command line : composer require zendframework/zend-mvc-plugin-flashmessenger
my composer is uptodate (composer self-update)

-[console output start]-----------------------------
Using version ^1.1 for zendframework/zend-mvc-plugin-flashmessenger
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don’t install zendframework/zend-mvc-plugin-flashmessenger 1.1.0
- Conclusion: don’t install zendframework/zend-mvc-plugin-flashmessenger 1.2.x-dev
- Conclusion: don’t install zendframework/zend-view 2.10.0
- Conclusion: remove zendframework/zend-view 2.8.1
- Installation request for zendframework/zend-mvc-plugin-flashmessenger ^1.1 -> satisfiable by zendframework/zend-mvc-plugin-flashmessenger[1.1.0, 1.2.x-dev, 1.1.x-dev].
- Can only install one of: zendframework/zend-view[2.10.x-dev, 2.8.1].
- Can only install one of: zendframework/zend-view[2.10.x-dev, 2.8.1].
- zendframework/zend-mvc-plugin-flashmessenger 1.1.x-dev requires zendframework/zend-view ^2.10 -> satisfiable by zendframework/zend-view[2.10.0, 2.11.x-dev, 2.10.x-dev].
- Conclusion: don’t install zendframework/zend-view 2.11.x-dev
- Installation request for zendframework/zend-view (locked at 2.8.1) -> satisfiable by zendframework/zend-view[2.8.1].

Installation failed, reverting ./composer.json to its original content.
—[console output end]-----------------------

what’s wrong ???

components already installed bellow

composer show
container-interop/container-interop 1.2.0 Promoting the interoperability of container objects (DIC, SL, etc.)
psr/container 1.0.0 Common Container Interface (PHP FIG PSR-11)
zendframework/zend-authentication 2.6.0 provides an API for authentication and includes concrete authentication adapters for common use cas…
zendframework/zend-code 3.1.0 provides facilities to generate arbitrary code using an object oriented interface
zendframework/zend-component-installer 0.7.0 Composer plugin for automating component registration in zend-mvc and Expressive applications
zendframework/zend-config 2.6.0 provides a nested object property based user interface for accessing this configuration data within…
zendframework/zend-db 2.9.3 Database abstraction layer, SQL abstraction, result set abstraction, and RowDataGateway and TableDa…
zendframework/zend-escaper 2.5.2
zendframework/zend-eventmanager 3.1.0 Trigger and listen to events within a PHP application
zendframework/zend-filter 2.7.2 provides a set of commonly needed data filters
zendframework/zend-form 2.10.2
zendframework/zend-http 2.6.0 provides an easy interface for performing Hyper-Text Transfer Protocol (HTTP) requests
zendframework/zend-hydrator 2.4.0 Serialize objects to arrays, and vice versa
zendframework/zend-i18n 2.9.0 Provide translations for your application, and filter and validate internationalized values
zendframework/zend-inputfilter 2.7.6 Normalize and validate input sets from the web, APIs, the CLI, and more, including files
zendframework/zend-loader 2.5.1
zendframework/zend-modulemanager 2.7.2
zendframework/zend-mvc 3.0.4
zendframework/zend-mvc-form 1.0.0 Metapackage with all requirements needed to use zend-form with zend-mvc.
zendframework/zend-mvc-i18n 1.1.0 Integration between zend-mvc and zend-i18n
zendframework/zend-router 3.0.2
zendframework/zend-servicemanager 3.3.0
zendframework/zend-session 2.8.5 manage and preserve session data, a logical complement of cookie data, across multiple page request…
zendframework/zend-stdlib 3.1.0
zendframework/zend-uri 2.5.2 a component that aids in manipulating and validating ┬╗ Uniform Resource Identifiers (URIs)
zendframework/zend-validator 2.8.2 provides a set of commonly needed validators
zendframework/zend-view 2.8.1 provides a system of helpers, output filters, and variable escaping
zfcampus/zf-development-mode 3.1.0 Zend Framework development mode script


#2

You’ll need to upgrade zendframework/zend-view first: https://github.com/zendframework/zend-mvc-plugin-flashmessenger/blob/1.1.0/composer.json#L23


#3

I found by myslef…

the zend-view module I used was 2.8.1, but required is 2.10 !!!
after update ( c:> composer update zendframework/zend-view), installation is ok !!!
now i use zend-view module 2.10.0
and the composer require zendframework/zend-mvc-plugin-flashmessenger command worked like a charm !

maybe this can help someone…


#4

I found while you wrote your answer… but many thx for your reply :slight_smile: