Migration from v1.8 to 3.0.3 questions

zf1

#1

I am currently investigating how to migrate a code base from Zend Framework 1.8 to 3.0.3 so that I can properly unit test. What are the best practices in doing such a thing as I’ve not attempted it.


#2

Follow the migration path first to version 2, then to version 3. If you do so in a stepped way like the above, you should have few problems. Ask further questions here or in the slack as they arise.


#3

One thing I am not grasping is why I am getting “Fatal error: require_once(): Failed opening required ‘Zend/Application.php’ (include_path=’:.:/Applications/MAMP/bin/php/php7.1.8/lib/php’)”

why is it looking for the application.ini file in the MAMP/…/php folder not the folder for the application. Im not even using MAMP to run this localhost.


#4

I misunderstood the question; I thought you were talking about Zend Expressive, but you were talking about a Zend Framework MVC application.

Unfortunately, there is no migration path; ZF2 was a complete rewrite of the MVC, and it wasn’t possible to migrate directly from v1 to v2 without significant changes in your application.

You will need to migrate manually. We generally suggest Expressive as being a closer fit for ZF1 users.


#5

You misunderstood the error message. Not the application.ini is missing, the include path is wrong and therefore the ZF1 can not be found.