ProxyManager with ZF3


#1

Hi,

If you are familiar with ocramius/proxy-manager, Please help me out.

I am having issues installing it on ZF3, it gives dependency issues with zend-code.

$ composer require ocramius/proxy-manager
Using version ^1.0 for ocramius/proxy-manager
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don’t install ocramius/proxy-manager 1.0.2
- Conclusion: don’t install ocramius/proxy-manager 1.0.1
- Conclusion: don’t install ocramius/proxy-manager 1.0.0
- Conclusion: don’t install ocramius/proxy-manager 1.0.0-beta3
- Conclusion: don’t install ocramius/proxy-manager 1.0.0-beta2
- Conclusion: don’t install ocramius/proxy-manager 1.0.0-beta1
- Conclusion: remove zendframework/zend-code 3.1.0
- Installation request for ocramius/proxy-manager ^1.0 -> satisfiable by ocramius/proxy-manager[1.0.0, 1.0.0-beta1, 1.0.0-beta2, 1.0.0-beta3, 1.0.1, 1.0.2, 1.0.x-dev].
- Conclusion: don’t install zendframework/zend-code 3.1.0
- ocramius/proxy-manager 1.0.x-dev requires zendframework/zend-code >2.2.5,<3.0 -> satisfiable by zendframework/zend-code[2.2.10, 2.2.6, 2.2.7, 2.2.8, 2.2.9, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.4.0, 2.4.0rc1, 2.4.0rc2, 2.4.0rc3, 2.4.0rc4, 2.4.0rc5, 2.4.0rc6, 2.4.0rc7, 2.4.1, 2.4.10, 2.4.11, 2.4.12, 2.4.13, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.4.7, 2.4.8, 2.4.9, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.6.0, 2.6.1, 2.6.2, 2.6.3].
- Can only install one of: zendframework/zend-code[2.6.0, 3.1.0].
- Can only install one of: zendframework/zend-code[2.6.1, 3.1.0].


#2

You’ll need to bump those dependencies: ProxyManager 2.x has been out for years.